Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorfanaticweb
    • CommentTimeNov 14th 2010
     

    Hey Simon, I stumbled on my first glitch and I was wondering, what exactly is needed for OIO to scan and find the expected link?

    The client I'm dealing with has explicitly published my link on his site under the form of Text (3 words) and this text links back to my site, yet, when he tries submitting a link exchange, he gets the error: Unable to find 'My Link' when checking the URL on 'your page'.
    Does he have to literally write "http:www.mypage.com" on his page for OIO to detect it?
    If so, what happens when an image banner exchange takes place?

    Just a heads-up, I got the No-Follow attribute set to Yes in case this is blocking it.

    Would appreciate your feedback, no rush, I know you're overwhelmed on here, thank you in advance.

    Liam

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeNov 14th 2010 edited
     
    Project Admin

    The string that OIO searches for on the client's website is either of the following:

    href='%link-you-specified%'

    href="%link-you-specified%"

    The only difference being whether single or double quotes are used in the link.

    It will search for the exact url you enter for the link exchange, so if the url in the "href" attribute on the client's site is not identical, then it won't be found.

    If you've confirmed that they are identical, then it might be that OIO can't make a connection to the client's site. To check whether that might be the case, you can do a simple test by opening the file "include/purchase.php" and finding:

    $page_check = @oiopub_file_contents($item->link_exchange);

    Just below that line, add:

    print_r($page_check);

    Then try submitting a purchase yourself, using the link exchange url, and see if the source code for the client's site appears at the top of the screen (and whether you can see the link in there). If it doesn't, then we'll know it is a connection issue.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeNov 14th 2010
     

    I added the code print_r($page_check); yet no code appeared, I even tried it as $print_r($page_check); thinking maybe you forgot the "$" sign, still no code, meanwhile, I even went and applied the link on his page to an image banner, thinking that maybe because he was using Text only was the issue, to no avail, still getting the error (Unable to find 'My Link' when checking the URL on 'your page').
    Should this be a connection issue, how can I go by educating that client on the next step? What exactly needs to be activated/triggered in order to allow this mutual connection?
    I'll try it on my own site putting in my own link to see if this is a connection issue after all.

    Thank you for the quick followup Simon, hope we can narrow this one down eventually.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeNov 14th 2010
     
    Project Admin

    If it works ok for you (putting a link on your site), you might want to send me the link from your client, to see if I can get it working.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeNov 14th 2010
     

    Hey Simon, sadly it didn't work for me neither despite placing my own page link, I don't get it though, am I the only one having this issue? Is it something related to the htaccess file or on the server side?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeNov 14th 2010 edited
     
    Project Admin

    Try unzipping and uploading the attached php file to your OIO directory, then running it in your browser:

    eg. http://yoursite.com/path/to/oiopub-direct/test_conn.php

    If the script successfully connects to the remote site (in this case, oiopublisher.com), you'll see the OIO home page, otherwise you'll hopefully see some kind of error.

    If that works correctly, try opening the file and replacing the oiopublisher.com url with that of your client's website and re-running it.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeNov 14th 2010
     

    Alright here we go: (for privacy purposes, I simply replaced the website name with Domain since it doesnt really affect this troubleshooting:

    Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /homepages/htdocs/domain/wp-content/plugins/ads/test_conn.php on line 17

    Warning: fopen(http://www.oiopublisher.com) [function.fopen]: failed to open stream: no suitable wrapper could be found in /homepages/htdocs/domain/wp-content/plugins/ads/test_conn.php on line 17
    string(0) ""

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeNov 15th 2010
     
    Project Admin

    Ah, that's the problem then. You'd need to ask your host to enable the fopen php function (and fsockopen too, if that's disabled), otherwise OIO can't make requests to other sites to check the link exchange.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeNov 16th 2010
     

    Sorry for the delay, I'll look into it and explore the security gaps of this task, since opening socks can be vulnerable for the server if I understand correctly.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeNov 17th 2010
     

    Alright so I called the Host and they advised me to create a Php.ini file and include the following in it:
    allow_url_fopen = on
    allow_fsockopen = on (not sure if this one is required though, will test it without it at first)
    Now, apparently this Php.ini file will only affect the folder where it's placed in, unlike .htaccess which affects the root server and folders as well.
    My question is, when dealing with OIO, where/what folder do I place this Php.ini file?

    By the way, I'm not a programmer, but I'm loving the learning curve on here, this thread might come in handy for other users who stumble upon the same issue.

    Let me know for the destination of the file, cheers!

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeNov 17th 2010
     
    Project Admin

    I'd place the php.ini file in the root directory of the site itself. That will ensure that both OIO and WordPress (assuming you're running it) can use those functions as required to perform tasks.

    PS. turning on fsockopen is a good idea in this case, because OIO uses it to run shceduled tasks. Without it enabled, things like auto-expiration of ads would be unlikely to work.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeNov 22nd 2010
     

    Simon, I didn't forget about this thread and I will definitely be providing the outcome of this step, I'm just waiting for a Theme update on my end and I'm in the process of reloading the site, until then, gotta make sure all settings are up and running before I start deploying any plug-ins, stay tuned.

    Need help?  Quick start guide | Troubleshooting | All help topics
  1.  

    Hey Simon, I'm back and just a heads-up, I upgraded to the latest version without any issues, worked flawlessely, yet I'm still getting the error:
    Unable to find 'My Link' when checking the URL on 'your page'
    whenever I try applying the Banner exchange ad submission.

    The good news though is that when I ran the test_conn.php test, this time it worked after I placed a copy of the php.ini file into the OIO folder, last time when I tested it out and it failed with the error:

    Warning: fopen() [function.fopen]: URL file-access is disabled in the server configuration in /homepages/htdocs/domain/wp-content/plugins/ads/test_conn.php on line 17

    Warning: fopen(http://www.oiopublisher.com) [function.fopen]: failed to open stream: no suitable wrapper could be found in /homepages/htdocs/domain/wp-content/plugins/ads/test_conn.php on line 17
    string(0) ""

    I had the Php.ini file in the root of the domain only and not in the OIO plugin folder, so that worked fine, the test went through and brought me to OIO's website.

    Yet, its still not working with other websites :(

    Any clue at what it could be? Does the other website need to have any modifications done?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJan 5th 2011 edited
     
    Project Admin

    Just so I'm clear - the "test_conn.php" file works when trying to access OIOpublisher.com, but not when you try to access another webiste (eg. the client's) using the same file?

    Need help?  Quick start guide | Troubleshooting | All help topics
  2.  

    Correcto, like I said, I had to include a second php.ini (same content as the other one in regards to the fosckopen) file within the OIO plugin folder for it to work, I took a wild guess trying it and I'm glad that worked.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeJan 5th 2011 edited
     

    Heads up once again: Just to give you an insight from my end, all the tests that I'm doing are based on internal domains hosted under the same shared hosting server: Domain 1 has the OIO installed as plugin on a Wordpress based theme, Domain 2 is just a plain HTML regular page, no Wordpress whatsoever.

    I can PM you the links to each of the domains if you need to look into the page sources.

    Need help?  Quick start guide | Troubleshooting | All help topics
  3.  

    OK ! I got good news! lol It worked, and I'll elaborate but I'm not 100% sure if I identified the real root cause here:

    I set up 2 kinds of ad space:
    1. Header Zone allowing a 728x90 banner
    2. Footer zone providing 4 slots of 125x125 each.

    The issue:
    I was choosing the Footer zone yet the submitted banner was a 728x90 dimensions.

    I think what needs to be done here is changing the error code to help identify the mistake that the user is doing, I'm trying to submit a 728x90 banner to fit it in a zone of 4 slots 125x125 which obviously wont work.
    But the error message is not clear on that part, yet it points out that the Link is not working.

    Get it?

    I'm gonna add a different Ad zone, OR, I'm just gonna submit a 125x125 banner to see if this confirms the resolution.

    Need help?  Quick start guide | Troubleshooting | All help topics
  4.  

    Wow! it either doesn't work, or it works no matter what banner dimensions we submit.

    Tried another test, this time I chose the Footer ad zone (125 x 125), down to 2 slots out of 4 available, great, at least the system recognizes that part.

    But the dimensions of the banner I submitted was 728x90, and it still went through, luckily we can manually validate this part, shouldn't OIO recognize the conflict in banner sizes vs the Ad zone banner sizes of the proposed ad slots and alert the user of this sort of conflict?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJan 6th 2011 edited
     
    Project Admin

    Hmmm...I just ran a test using the latest version, with a 125x125 ad zone and the exchange option enabled. I tried to upload a 468x60 ad and got the expected error message:

    "Please use a valid 125x125 banner image"

    I did just have one thought - did you by any chance disable banner image uploading? If so, try enabling it, as I don't think the remote url option has size validation.

    Need help?  Quick start guide | Troubleshooting | All help topics
  5.  

    Updating the results of this thread:

    For the record, this worked out great, the only tip I have is:

    To add the Php.ini file in the OIO publisher folder as well, not just in the root!

    Need help?  Quick start guide | Troubleshooting | All help topics