Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthornyunyu
    • CommentTimeJul 18th 2011
     

    I have installed OIO on my wordpress blog.
    Installation went fine as usual but I have trouble with Rewrite Script URL.

    OIO suggested me to put this into my htaccess:
    ## OIOpublisher Rewrite
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^http://shop.astronyu.com/(.+)$ wp-content/plugins/oiopub-direct/$1 [L]

    But when I place it in htaccess, it won't work.
    I've tried:

    1- first try
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^http://shop.astronyu.com/(.+)$ wp-content/plugins/oiopub-direct/$1 [L]

    - 2nd try
    # OIOpublisher Rewrite
    <IfModule mod_rewrite.c>
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^http://shop.astronyu.com/(.+)$ wp-content/plugins/oiopub-direct/$1 [L]
    </IfModule>
    # OIOpublisher Rewrite

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthornyunyu
    • CommentTimeJul 18th 2011
     

    My oiopublisher purchase page is at
    http://www.astronyu.com/wp-content/plugins/oiopub-direct/purchase.php

    Now if I use cpanel redirects, it won't load the page at all.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthornyunyu
    • CommentTimeJul 18th 2011
     

    Simon, can you help?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 18th 2011
     
    Project Admin

    The "1st try" looks correct, but shouldn't it be www.astronyu.com rather than shop.astronyu.com (going by the url you posted)?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthornyunyu
    • CommentTimeAug 24th 2011
     

    Hmm..why isn't any of the replies here went to my inbox. weird.

    Anyway, reason for the shop.astronyu.com was because I specify in OIO setting in the rewrite field to have new url.

    Because instead of having http://www.astronyu.com/wp-content/plugins/oiopub-direct , I want it to be http://shop.astronyu.com

    Can you help Simon?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthornyunyu
    • CommentTimeAug 24th 2011
     

    And now I tried this.
    ## OIOpublisher Rewrite
    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^advertise/(.+)$ wp-content/plugins/oiopub-direct/$1 [L]

    to get this
    http://www.astronyu.com/advertise

    but it doesn't work.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthornyunyu
    • CommentTimeAug 24th 2011
     

    Found out how to make it work.
    Put it before the wordpress rules.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeAug 24th 2011
     
    Project Admin

    Thanks for the update.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthoradjunkye
    • CommentTimeAug 27th 2011 edited
     

    Thanks for the info!
    Working great...

    Need help?  Quick start guide | Troubleshooting | All help topics