Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorfanaticweb
    • CommentTimeJul 28th 2011
     

    Simon, I know that this feature can be turned on or off from the settings (Allow users to upload banner) but I was wondering if its possible to allow the admin to insert a file path when it comes to the Manual ad publishing?

    Not sure if this is something that was requested or if you might plan on pushing it in the future, would be nice to have the flexibility to do so from the admin side.

    Cheers

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 28th 2011 edited
     
    Project Admin

    It isn't something that can be done currently. With the exception of default ads, everything else uses the same system.

    What's the use case for needing a different method via the admin area?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeJul 29th 2011 edited
     

    The main reason being is for someone that runs multiple sites such as in my case, when pushing manual ads, I'm stuck uploading the same image repeatedly on multiple domains. I dont mind if the advertiser has to go through that process since they usually choose on which site they want to place the banner, and I cant opt for cross-site advertising after all since the target sites are not always the same content (meaning, setting advertising based on banner size and zones instead of site content is not an option).

    Giving me the option to use the File path instead of upload will reduce the multiple instances of banners located across the server occupying space that could be reduced to just one banner for all sites.

    As a matter of fact, if this can actually be done (on a customization basis) let me know as I would be very interested in getting this flexibility applied.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 30th 2011 edited
     
    Project Admin

    Having thought about it, a think it should be relatively simple.

    Re-upload the following files from the latest code:

    * /edit.php
    * /templates/core/purchase_edit.tpl

    When you go to the edit page, just add &upload=false to the end of the url and refresh the page. It should swap the upload box for a standard input box.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeJul 31st 2011 edited
     

    Did you edit your post? Cause I just refreshed this page and I was sure you had posted something else, it had to do with the edit.php file only and to simply add the following code to it which actually worked on the edit.php file:


    //disable image uploading on this page only
    $oiopub_set->general_set['upload'] = 0;

    Does the new code actually allow both methods? Upload or path of the file pending on adding that "&upload=false" in the link?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 31st 2011
     
    Project Admin

    Yes, sorry, I did edit it (as I thought it would be easier to add it in as a conditional change. Follow the directions in my edited post instead.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfanaticweb
    • CommentTimeJul 31st 2011
     

    Alrighty then, will do so tonight, I'm sure its gonna work since the previous code did the job as well, I'll update the post once tested :)

    Need help?  Quick start guide | Troubleshooting | All help topics
  1.  

    Hey Simon, I uploaded the latest files and it works when it comes to switching back and forth with the link addon, although I cant seem to get the following simple text to show up on the page:

    File: Purchase_edit.tpl
    Line 162:

    <td width="140" valign="top"><b>Banner Upload (or use &upload=false to specify the file path):</b> [<a href...

    I just wanted to add a self note for reference purposes and it wont update, as a matter of fact, any changes I do in that .tpl file wont update or reflect online, am I using the wrong file to complete this task?

    Need help?  Quick start guide | Troubleshooting | All help topics
  2.  

    Nevermind the previous post, I'm sure its something from my end as it seriously didnt make sense, since nothing would update whenever I modified that template, might be the wrong version on the server or something else minor.

    Remember when I mentioned to you that doing a Copy/Paste is pasting the path link in capital letters? I'm still wondering why it's happening or if i'm the only one experiencing this glitch.

    It didnt bother me much before since I just typed the path links manually, but now i'm trying to copy paste over 50 links and the target server I'm dealing with has a case sensitive issue (meaning if the slightest character doesnt match, the link wont work).

    Its not a MAJOR issue but just hoping if you have a quick fix for it or if I'm actually the only one with this issue.

    Thank you as always for your support.

    Need help?  Quick start guide | Troubleshooting | All help topics