Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorjshare
    • CommentTimeJun 24th 2008
     

    My tracker was working fine and a weekly report was sent to my advertisers in the first week of June. Today, one of my advertisers asked why there's been no report since.

    Other emails have been going out so I know that's not the problem. The only anomaly I've seen is the warning in the Manual Update:

    "The tracker archive guard is currently active, to stop multiple results being archived. This means that no further archive updates can occur.
    If this message persists, please reset the tracker guard by clicking here"

    So I clicked "clicking here", the page refreshes and the warning is gone, so now I assume stats will be recorded again. However, I can make the warning reappear by clicking either the "Last 7 Days" or "Last 30 days" filtering links.

    Any suggestions?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorjshare
    • CommentTimeJun 24th 2008
     

    It's even worse than I thought. Whenever I click on the OIOPublisher > Tracker to get to the Tracker page, the warning is appearing.

    It seems that the stats stopped being recorded when I upgraded to OIO 1.61, paypal 1.05.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJun 24th 2008 edited
     
    Project Admin

    Just checked the demo and the stats are still ticking over there, so my best bet is that the settings got screwed on the upgrade somehow.

    The "uninstall" option only removes the option variables, not the database tables (ie. the advertiser / purchases data). Therefore you might want to try an uninstall, then install again and re-configure the settings. Might even be worth deleting the folder and re-downloading the entire plugin to rule out any old code that might be lurking.

    If you do go down that route, you'll want to back up the database before trying it.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorjshare
    • CommentTimeJun 24th 2008
     

    Doh! That sucks and isn't very encouraging. Did you do an upgrade for the demo or install from scratch?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJun 24th 2008 edited
     
    Project Admin

    Just an upgrade - I always do that with the demo.

    The only reason I say try a full re-install is because we don't have any clues to go on; you're the only person to have reported an issue at this point. You're a test case really. ;)

    If a clean install (of the settings) works correctly, then we know it was just a glitch in the upgrade, or the cron system etc. If however it were to still give you the warning, we'd know there is definitely something up with the code somewhere.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorjshare
    • CommentTimeJun 24th 2008
     

    Yeah, I know. Doesn't mean I have to like it :)

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorjshare
    • CommentTimeJun 25th 2008
     

    Added twist - although I'm not seeing the stats, the tracker was definitely working throughout the month. I can see this because of the way my hosting company - MediaTemple - profiles my server processes. In fact, the tracker script used almost 25% (!) of my June server resources allotment, which is far too much so now I'm considering disabling it altogether.

    To be precise, the resource-hungry script is modules/tracker/tracker.php. Is the purchase tracking module the only one calling that file?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJun 25th 2008 edited
     
    Project Admin

    If you're host has access to the shared memory functions (shmem) then 2.0 will sort out the resources issue for you.

    The problem is that unless you have access to something like shared memory (or potentially memcache) then an INSERT database query has to be called on every page load (to insert the stats data), which is expensive. That's most likely what is eating up the resources.

    OIO 2.0 will detect whether your host has enabled shared memory, and if so, allocate a 1mb block to the storage of page hits. A cron job will then be called every 10-15 mins to load the stats into the database. That should drop the load to almost zero.

    I don't think there is any way to reduce the resource usage otherwise.

    Let me know when you're able to do a test re-install, and whether the stats issues continue after that point.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorjshare
    • CommentTimeJun 25th 2008
     

    Just a reminder- I'm on WPMU 1.3.1.

    Simon, here's what I did in my test WPMU environment:

    1. Backup db
    2. Uninstall plugin
    3. Reactivate plugin
    4. Starting with Settings > General, begin copying settings from my production environment to the test environment. With each page of settings updated, refresh the Tracker page in a separate Firefox tab. Everything went fine until I updated the Links page, and that's when the tracker guard warning came back.

    I then diff'ed a fresh download with what I had in my test environment. Sure enough, there were differences. However, my trac timeline shows that I did the upgrade to 1.61 manually, poorly apparently. So the problem isn't the upgrade mechanism.

    All db tables are where they need to be, so I don't think it's a WPMU issue.

    I did a clean reinstall in my test environment and the warning appeared again but I wasn't very systematic so I couldn't say what triggered it.

    I then did a clean reinstall in my production environment and saw that the tracker guard warning appears after I updated the Emails page (even earlier than the Links page, by the method I described above). But I don't think it's related to the emails page, I think it's related to how the db is being written to.

    I currently have 2 blogs using OIO in production. After doing some more testing, I also noticed that I can get the warning to appear in each blog's admin panel by clicking a Preset Date Filters link or by clicking the OIOPublisher > Stats Tracker menu item. However, if I click to reset the tracker and get rid of the warning, clicking on Update Settings/Update Now/Filter by Date/Filter by ID will refresh the page without generating the tracker guard warning.

    Final thing that I discovered. Blog #1 had no stats recorded for June, but Blog #2 has stats for the whole month.

    Over 3 hours later, I'm kind of fed up with OIO today...

    Hopefully you can make something of my results.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJun 25th 2008 edited
     
    Project Admin

    Oh geez, WPMU... that does complicate things.

    On the test environment / other blogs you have it running on, are they WP or WPMU installs? I'm going to try and re-create what you've described on a test WP install, but we also need to know whether this is a WPMU specific problem.

    Thanks for all the testing you've managed to do so far; definitely time to take a break from it. ;)

    As a side note, regarding WPMU, I have enlisted the help of Andrea to look at OIO 2.0 once it's ready for testing, to make it is fully WPMU compatible.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorjshare
    • CommentTimeJun 26th 2008 edited
     

    My test environment is one WPMU install. It's actually a Subversion branch where the trunk is my production environment, so the code is usually >99% identical.

    Each WPMU install has 3 blogs set up. Normally they would need to be in subdomains or subdirectories of one domain, but using a WPMU plugin called Multi-Site Manager, each blog is under its own domain.

    I don't have any straight WP installs anywhere.

    Bringing Andrea on board is a great idea and you're lucky to be able to do so. That's great news.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJun 26th 2008 edited
     
    Project Admin

    Would it be a big loss to disable the tracker for now? It's definitely a problem specifically related to WPMU from what I can tell. I can't replicate the problems on a normal WP install.

    I feel it might be more worthwhile at this stage concentrating on the development of 2.0 and then getting someone (ie. Andrea) to make sure it is fully WPMU compatible.

    Out of interest, is this the only element of the script not working correctly at the moment?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorjshare
    • CommentTimeJun 26th 2008
     

    No it wouldn't be a big loss because it ain't workin' anyway :)

    I turned it off for Blog #1 but left it for Blog #2 since there stats are actually being recorded. I'm also curious to see how this affects my server resource report.

    I 100% agree with your sense of priorities. Onward to 2.0!

    Regarding your question, this tracker guard warning is the only anomaly I've experienced with OIO recently.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorxorsyst
    • CommentTimeJun 30th 2008
     

    I actually just discovered this problem tonight as well. Im running the standard Wordpress 2.5.1, and not MU. After I click the 'reset tracker guard' link, the warning goes away only to come back when I click on the 'tracker' menu link just as jshare said.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJun 30th 2008 edited
     
    Project Admin

    I'll take another look into it today in that case.

    Did you discover the problem just after an upgrade, or was it not prompted by anything?

    EDIT: I've made a small tweak to the tracker module. If you could download it and let me know if it fixes the guard issue for you.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorxorsyst
    • CommentTimeJun 30th 2008
     

    I just updated my OIOPublisher, and noticed a few modules were out of date, including the core files. I upgraded everything. Sadly, the tracker issue is still there though. Same exact problem. I never tested the tracker module upon installing OIOPublisher. I just had my first buyer, and then decided to see if it was working (because OIOPublisher doesn't track default space filling ads.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJun 30th 2008
     
    Project Admin

    I'm still unable to replicate it unfortunately.

    If you want to shoot me over some temporary FTP / blog login details at some point, I can have a look at it in more detail for you.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorjshare
    • CommentTimeJul 1st 2008
     

    Simon, is your tweak in the 1.04 module?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 1st 2008
     
    Project Admin

    Yes, just a quick change made to the 1.04 module.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorxorsyst
    • CommentTimeJul 1st 2008 edited
     

    Sent over some details, hope you have better luck at spotting the issue. Thought it may have been a conflict with my cache plugin, as it seems to be the vain of a lot of conflicts, but after turning it off, I still get the warning message.

    Need help?  Quick start guide | Troubleshooting | All help topics