Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorianternet
    • CommentTimeSep 12th 2007
     

    hi all I just made a sale with banner advertising - it is still manual I would like to see this go automated like text and posts. but in any case the end user has paid but OIO status says unpaid. is this an issue or known issue? how will I know when to remove the banner? (I gave myself a scheduled reminder on my calendar) but anycase how does OIO know it was paid for? since its still saying its unpaid?

    the manual part I do not mind but would like to see this be automated (uploaded to the wp-upload folder and deleted once expired) but that is my main issue - how do I know if it was paid or not, besides logging into paypal etc.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeSep 12th 2007 edited
     
    Project Admin

    Custom services should have the payment status updated automatically. I'll do a test run-through later in case it isn't updating correctly though. I've also added an email to the blog admin upon a custom service expiry, so that will be available in the next version. Maybe I'll try and come up with a more fancy notification system in the future, but for now, emails to admin should suffice.

    EDIT: just tested it using sandbox, and the payment status was updated via the IPN automatically. It may just have been a fluke with paypal not sending the data or something of that nature.

    If you want to, you can always get a PayPal sandbox account at: https://developer.paypal.com and test out the payment interface for yourself. If you do that, remember to open up oiopub-direct/index.php and change the $oiopub_sandbox variable at the top, from 0 to 1. Also remember to change it back once you've completed testing!

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorianternet
    • CommentTimeSep 18th 2007
     

    thanks - I had to update my sql data with the proper time - took me a while to figure out the time in the sql database - so I am assuming it might have been a fluke within paypal not sending the IPn iguess?

    thanks!

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeSep 18th 2007
     
    Project Admin

    I think it could well have been a fluke. PayPal had some problems with their IPN recently (although mainly with subscriptions), so you could have caught them at a bad time.

    Need help?  Quick start guide | Troubleshooting | All help topics