Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorswisss
    • CommentTimeMar 3rd 2012 edited
     

    Installed OK but ...

    1) Where do I add the page title and description meta tags? This is on a Wordpress install using Yoast's SEO plugin. The OIO pages being in the wp-contents/plugins/ ... folder are not available to the SEO plugin

    In the browser tab it is showing the page url whereas I want it to show the page title metas as it does on all the other pages.

    2) I'm not very happy at having the pages in the ...wp-content/plugins/oiopub-direct/ folder. Is it possible to copy the template tags or whatever for OIO into actual WP pages (which would then allow the title / description metas to be added via the SEO plugin).

    Or is there a better solution to these problems?

    Many thanks

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMar 3rd 2012 edited
     
    Project Admin

    The OIO pages are entirely separate from WordPress, since it's a standalone app that integrates with the WordPress platform. Therefore, as it stands, there's no simple way to switch it around (so that OIO elements are pulled into WordPress pages).

    That rules out being able to use the SEO plugin.

    A couple of things you can do, as an alternative solution:

    1.) Use OIO's "rewrite rule" option in the admin area to change the url (e.g. from /wp-content/plugins/oiopub-direct to /ads).

    2.) Use OIO's "purchase url redirect" option in the admin area to send users to another page when they click "advertise here", instead of the default OIO purchase page.

    The first one is purely cosmetic, to change the url. The second one would allow you to create your own WordPress-based sales page, which you could then link to OIO's purchase form.

    P.S. OIO already uses a robots.txt file that blacklists spiders from everything, except the "purchase.php" page. If you create your own sales page, you could extend it to blacklist the purchase page as well.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorswisss
    • CommentTimeMar 3rd 2012
     

    Wow! thank you for your most prompt response, and on a Saturday too!

    Yes, I'd starting thinking along the lines of option 2 which would work OK.

    I'd misunderstood option 1 thinking it would redirect from the oio page to the wordpress advertising page I'd created and obviously it didn't, but now I see how it works and that it will mask the url, all is looking good - so far anyway.

    Many thanks again!

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorswisss
    • CommentTimeMar 3rd 2012
     

    .htaccess problems.

    Just so that I understand this - in the 'Rewrite Rules' I'm assuming that as this is just acting as a 'mask', the URL must point to a page on the domain that doesn't actually exist?

    Existing wordpress .htaccess file contents


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    code generated by OIO


    ## OIOpublisher Rewrite
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^advertising-booking/(.+)$ wp-content/plugins/oiopub-direct/$1 [L]

    I've tried slotting in the one missing line both before and after the last 'Rewrite' rule, and every other possibility, but they all return 404's on .../wp-content/plugins/oiopub-direct/purchase.php and all the sites pages are screwed up displaying without the style sheet.

    I've restored the original .htacess file and removed the OIO settings. The site displays OK on another PC, so I deleted the cookies but can't get it to display properly on the original PC although the settings are back to what they were, but presumably this will clear in due course.

    I've run out of combinations to try on the .htaccess file, unless the page does have to exist, can you please advise?

    Many thanks.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMar 3rd 2012 edited
     
    Project Admin

    Hmmm... try something like this (after re-enabling the OIO url rewrite setting):

    ## OIOpublisher Rewrite
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^advertising-booking/(.+)$ wp-content/plugins/oiopub-direct/$1 [L]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    If that doesn't work, check to see if there are any other htaccess files on your site that could be affecting it (e.g. in the plugins folder, or even outside of the root WordPress directory).

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorswisss
    • CommentTimeMar 3rd 2012 edited
     

    Hello Simon

    Thanks again for your help!

    Unfortunately it's still the same and I've checked for other .htaccess files and none found

    ** Just to make sure I'm understanding this and not expecting it to do something else .....

    http://www....com/wp-content/plugins/oiopub-direct/purchase.php does call the order form start page but still displays this url in the browser address bar and page tab.

    http://www......com/advertising-booking - generates a 404 error (the page doesn't exist - still not sure whether I'm supposed to create it?)

    I assumed the entry in the .htaccess file was so that the .../advertising-booking URL would either call the ../purchase.php, and/or display as the URL for ../purchase.php in the browser address bar and page tab.

    Am I understanding this correctly, or have I gone off at a tangent somewhere?

    (EDIT - I created .../advertising-booking/ page, just to see if that would resolve the problem, but still the same)

    Sorry for being a bit thick - it's 11pm here in the UK and I've been working on this site since first thing this morning and I'm losing the plot :-)

    2nd Edit - Instead of messing with the .htacces file, would it work if I entered the URL directly into config.php?


    /*
    PLUGIN URL
    allows you to set the url the script is located at
    */

    $oiopub_set->plugin_url = ''; //for example: http://www.mysite.com/path/to/oiopub-direct (no trailing slash!)

    Many thanks again!

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMar 4th 2012 edited
     
    Project Admin

    Ah ok, maybe I didn't explain it very well initially. The only thing the url rewrite does is "shrink" the folder structure. It still uses purchase.php, it just replaces:

    /wp-content/plugins/oiopub-direct/purchase.php

    With:

    /advertising-booking/purchase.php

    You don't need to create an "advertising-booking" page on your site or change the "plugin url" option, in order to use OIO's url rewrite option.

    Creating your own sales page and re-directing users to it is completely separate to the url rewrite (and probably the thing that will yield the most benefit to you, for meta tags etc).

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorChamoi16
    • CommentTimeNov 12th 2018
     

    Well, I still have to understand a lot of terms that come under seo services because little knowledge is dangerous and I don’t want it to affect my business promotion in any way. I am glad that I found this post online, as I will be able to talk about all the related terms here.

    Need help?  Quick start guide | Troubleshooting | All help topics