Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthoraddamroy
    • CommentTimeJul 29th 2012 edited
     

    Why on earth is there no form of wysiwyg or other text customization features in the post body area for a paid post?

    Users cannot even bold, italicize, align, underline, insert hyperlinks or ANYTHING AT ALL to the text of their submission...

    I'd like to see this happen or I can't really utilize this feature of the software.

    Please reply ASAP and let me know what we can do about this or I might have to find an alternative.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 29th 2012 edited
     
    Project Admin

    OIO has used the TinyMCE editor (from WordPress) since it was first created. Check out the source code of the "posts" purchase form for confirmation.

    There was an issue a while ago where it stopped working, because the WordPress implementation of the editor changed - it's possible something like that could have happened again, so I'll check it out.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 29th 2012 edited
     
    Project Admin

    It does look like something broke. I've made a change to OIO to fix it and all looks to be well again.

    You just need to grab and re-upload a couple of files from the latest code:

    * /platform/wordpress/functions.php
    * /templates/core/purchase_posts.tpl

    It will revert to looking something like this. Please let me know whether this solves the issue for you, so that I can close off the fix.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthoraddamroy
    • CommentTimeJul 30th 2012
     

    Awesome thank you Simon!

    Support for OIO is A++

    The product itself is A++

    I apologize for the lack of effort comment, I didn't realize this was a bug I thought it was a missing feature all together. Going to edit that now.

    Thanks again, great program.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthoraddamroy
    • CommentTimeJul 30th 2012 edited
     

    Encountered another issue though.

    I'm using the Flexsqueeze Wordpress theme. You can see it here, www.FlexSqueeze.com

    And this theme adds a whole bunch of buttons to the editor to input things like buy buttons, headlines, and other graphical elements when creating a new post or page on wordpress.

    These extra buttons are showing on the editor, is there anyway to just show the standard buttons and not all the extra ones??

    I'll include a snapshot so you know what I'm talking about

    http://screencast.com/t/hG37oSOKsH

    I posted an inquiry about this on the flexsqueeze support forum as well, hopefully one of y'all will have a solution :)

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 30th 2012
     
    Project Admin

    I'm guessing the theme will be adding custom buttons to the editor, as below:

    >> http://codex.wordpress.org/TinyMCE_Custom_Buttons

    I'm not sure how to remove custom buttons at this point, but it would be useful to know how those buttons are being added initially.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthoraddamroy
    • CommentTimeJul 30th 2012
     

    I got a response from their support forum, managed to fix it.

    I had to remove a line of code from the functions.php file from the theme's route folder. Mission accomplished I think I'm good to go!

    Make sure you read my suggestion regarding the expiring paid posts and let me know your thoughts.

    Thanks simon I appreciate the help, if you want to know more about the code I had to remove to get the buttons to disappear we can chat direct and I can send you the code if that helps.

    Adam.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 30th 2012
     
    Project Admin

    Thanks for letting me know - if it was something resolved within the theme, then we can leave it be for now.

    Need help?  Quick start guide | Troubleshooting | All help topics