Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorfelthos
    • CommentTimeSep 23rd 2014 edited
     

    Hello Simon,

    I've had this problem in the past (forum topic), and it's now happening again.

    I suspect it has to do with the way my host is doing caching, so there may be no solution short of me moving OIO to a different host. What I'm wondering is if there are any new hacks/workarounds since that post (Jan 2013) that I can try out.

    PS> I tried upgrading from 2.55 to 2.56, but each time I get in and click the "Continue with Upgrade Now", I get kicked out back to the admin login page.

    Thanks!

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeSep 24th 2014
     
    Project Admin

    There is nothing different that I'm aware of, so I don't think there's anything else I can suggest beyond what was covered last time.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvh8091
    • CommentTimeAug 1st 2015
     

    I am having the same issue when installing on a new server (win 2012 server, apache 2.4) with version 2.55 or 2.60. I used to work on Win 2008 with apache 2.2.

    Everything works (showing banners/db updates on tables), except logging into admin server. Tried different (private) browsers, nothing works.

    Any hints?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeAug 2nd 2015 edited
     
    Project Admin

    Are you using OIO as a WordPress plugin, or standalone install? (I'm guessing it's probably the latter)

    The most likely thing I can think of is a problem with php session. It could be down to how it's configured on that server, or it could be the way OIO tries to handle them.

    In OIO's "include/functions.php" file is a function called "oiopub_session_start". Try replacing that function with this simpler version:

    function oiopub_session_start() {
    //session exists?
    if(session_id()) {
    return true;
    }
    //start session
    return session_start();
    }

    Then it just relies on php doing whatever the default setup is, rather than trying to do any configuration itself.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvh8091
    • CommentTimeAug 2nd 2015 edited
     

    Hi,

    Thanks for the quick answer. I am using it standalone. Unfortunately no luck, I also compared the phpinfo for the 2 servers, but I cannot see any strange things there.

    Kind regards,

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvh8091
    • CommentTimeAug 2nd 2015
     

    Found it.... It was an apache setting:
    Header edit Set-Cookie ^(.*)$ $1;HttpOnly;Secure

    I disabled it and it works now.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeAug 8th 2015
     
    Project Admin

    That's interesting, thanks for the heads up.

    Need help?  Quick start guide | Troubleshooting | All help topics