Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorn2rga
    • CommentTimeFeb 2nd 2015 edited
     

    I'm using the WordPress Version latest v2.56 on WP 4.1
    Ads not showing in FireFox and Chrome IE is OK
    Was working fine all this time since first using plugin a year ago.
    Verified on other computers.
    site is http://www.funtime247.com
    actually happening on all my sites same theme

    EDITED: I checked the Source and it is showing the code in source
    <div id="headbanner"> <script type="text/rocketscript" data-rocketsrc="http://funtime247.com/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=1"></script></div>

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorn2rga
    • CommentTimeFeb 4th 2015
     

    Still have this problem anyone Home?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeFeb 7th 2015
     
    Project Admin

    Judging by the code snippet (use of rocket), I would imagine that it's a conflict between FireFox, rocket and OIO.

    You could try switching to js_old.php? (instead of js.php#) to see if that makes any difference. If not, maybe exclude it from being changed by rocket?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorn2rga
    • CommentTimeFeb 7th 2015 edited
     

    I changed js.php to jsNEW.php and js_old.php to js.php but didn't make a difference.
    Cleared cache in browser and website.
    I also noticed that all the other lines of code say rocket.
    <script type="text/rocketscript" data-rocketsrc='http://www.funtime247.com/wp-content/plugins/goodbye-captcha/public/scripts/gdbc-public.js?ver=1.1.7'></script>

    Could this be from Cloudflare?
    I just answered my own question yes it is their rocket loader option.
    I turned it off and now showed invalid ad zone.
    So I renamed the js.php back to original and I'm back to normal but now my site loads slower in http://gtmetrix.com

    How do I fix this so I can use Rocketloader in Cloudflare?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeFeb 7th 2015 edited
     
    Project Admin

    I'm not overly familar with rocketloader, but I believe you can have it on by default, but just exclude certain scripts (e.g. OIO ads). That should give you the best balance between speed and compatibility.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorn2rga
    • CommentTimeFeb 7th 2015
     

    Fixed
    For anyone having this problem with ads not showing and using rocket loader in Cloudflare.
    Adding data-cfasync="false" before src="/javascript.js" Fixed it

    this is the way to fix it.
    As per Cloudflare's Help topic.

    You can have Rocket Loader ignore individual scripts by adding the data-cfasync="false" attribute to the relevant script tag, for example:

    <script data-cfasync="false" src="/javascript.js"></script>

    Rocket Loader will still work for all other scripts.

    Notes:

    1. Adding this attribute within JS will not work to exclude the script from Rocket Loader.
    2. The 'data-cfasync' attribute must be added before the 'src' attribute.
    3. Rocket loader will recognize the tag when either single or double quotes are placed around the attribute value.

    Alternative:

    If Rocket Loader is only impacting a specific URL, then please look at using a PageRule to exclude that URL from optional performance features.

    thank you for your help.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeFeb 7th 2015
     
    Project Admin

    No problem, glad you found the solution.

    Need help?  Quick start guide | Troubleshooting | All help topics