Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthortfooq
    • CommentTimeMay 8th 2015 edited
     

    OK, this is driving me crazy.

    Until recently, OIO ads used in the sidebar widget of the Wordpress theme eleven40 Pro (Genesis-based) worked perfectly. It worked great for well more than a year. Then one day, OIO gives me an error that the plugin isn't installed properly (don't know why). So I upgraded to 2.60 and that seemed to do the trick, except now the sidebar ads destroy the site layout on some/most browsers. In some browsers, it will work if you are not logged in, but will look crazy when you are logged in. (UPDATE: Client had AdBlock plugin installed, so there was no browser issue)

    This happens whether I use the OIO widgets or paste the javascript codes into text widgets.

    Every other widget and plugin I have works perfectly. It's only OIO that causes this issue. Remove the ad widgets, and everything displays perfectly. It shouldn't be an issue of sidebar width (it's wider than the ads). What should I try next? I'm running out of ideas. Thanks!

    UPDATE: Problem solved! See response below. It was the new fluid option.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMay 10th 2015
     
    Project Admin

    v2.6 introduced fluid ad zones (automatically adjusting itself to the width of the container), which is the most likely source of the issue.

    Try opening the OIO widget and set the "fluid" option to no, to see if that makes any difference.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthortfooq
    • CommentTimeMay 12th 2015
     

    Yes! That was totally the issue.

    Now I have a second problem: Whenever I switch the widget setting for fluid from yes to no, it won't stick. It keeps reverting back to yes. Any idea why this might be happening?

    For those looking for a workaround, you can use the javascript embed for your ad zone in a text widget. By default it will have the fluid option turned on, but you can add &fluid=false to the code. For example:

    <script type="text/javascript" src="http://yoursite.net/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=2&fluid=false"></script>

    But I'd love to use the OIO widget instead, since that's easier for my client to work with. Thanks!

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMay 17th 2015
     
    Project Admin