Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorvakory
    • CommentTimeMay 14th 2015
     

    Hello, Simon. I upgraded to v2.6.0 today and am now getting the following error when anyone tries to purchase or renew an ad. I'm also seeing this when clicking the "edit" link for each banner ad:

    This page contains the following errors:

    error on line 1 at column 335: Entity 'raquo' not defined
    Below is a rendering of the page up to the first error.

    The Virginia Beer Trail{"@context":"http:\/\/schema.org","@type":"WebSite","url":"http:\/\/www.vabeertrail.net\/","name":"The Virginia Beer Trail"}

    I'd appreciate any insight you might offer.

    Thanks much.

    Regards,
    Kory

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeMay 16th 2015
     

    Just wondering if I can do anything about this. I have a few people interested in purchasing ads and this is a holding them up.

    Thanks much.

    Regards,
    Kory

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMay 17th 2015
     
    Project Admin

    That's odd, not something I'm able to replicate with my test install.

    As a first step, could you try re-downloading the v2.60 files and uploading them to your site again? Just in case something went wrong with uploading the files first time round

    If that doesn't help, could you send me a link to your purchase page and I'll have a look at the error first-hand to see if I can work out where it comes from.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeMay 17th 2015
     

    Thanks your reply, Simon. I appreciate it.

    I attempted to re-download v2.60 and am getting the same results. I double checked to ensure the proper permissions and ownerships are set on the files on the server.

    Here's the link to my site's purchase page:

    http://www.vabeertrail.net/wp-content/plugins/oiopub-direct/purchase.php

    It looks like the error is that same there as well. I also continue to see it in the "edit" links for the banners which are currently there.

    I did some research on the error and the closest WP support thread I came across is this one:

    https://wordpress.org/support/topic/rss-raquo-problem

    I don't have an ampersand or other strange character within my site's title. I also had temporarily disabled the Yoast SEO plugin but the error still persisted.

    I also don't see anything in the server's error logs relating to this error.

    If there's anything else I can do on this end, please let me know.

    Thanks, Simon.

    Regards,
    Kory

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeMay 17th 2015
     

    I don't know if this is helpful, but since upgrading to v2.60, I noticed the RSS feed on the OIO settings main page is putting this out:

    This page contains the following errors:

    error on line 2 at column 1: Extra content at the end of the document
    Below is a rendering of the page up to the first error.

    I've attached a screenshot of what I'm seeing.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMay 17th 2015
     
    Project Admin

    It looks like it's trying to pull in meta content from a "feed" page (hence the strange error, the browser is trying to parse it as XML). Which I've never seen before.

    I can't think of anything that changed between v2.56 and v2.60 that would affect it like this. Can you try disabling all other plugins temporarily to see if the problem persists?

    The temporary solution would be to change the Theme back to OIO's default or sandbox (rather than using WordPress), so at least the pages will be accessible again.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeMay 17th 2015
     

    Certainly, Simon. I've attempted to change the OIO theme back to both default and sand box and am seeing a different error on the purchase page:

    http://www.vabeertrail.net/wp-content/plugins/oiopub-direct/purchase.php

    I'll look into temporarily disabling the other plugins later this evening as I don't want to break functionality in the middle of the day. I have a slew of events in my calendar that many people are accessing at the moment (it's late morning and a big event day here for me. The site averages about 1,000 unique visitors a day).

    Thanks much.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMay 17th 2015
     
    Project Admin

    The content-type response header is being returned as text/xml (so even though the response is html, the browser will still treat as xml). The question is where that's coming from.

    I don't think it's likely to be from OIO itself, so let's see how disabling the other plugins goes.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeMay 27th 2015
     

    Hello, Simon. I actually tried a few things:

    - Upgraded my theme to the latest version
    - Upgraded all plugins to their latest versions
    - Tried disabling each plugin one by one but it didn't make a change.
    - Re-uploaded v2.60 of OIO.

    When I visit the sign-up page in Firefox, I'm seeing some strange XML parsing here:

    http://www.vabeertrail.net/wp-content/plugins/oiopub-direct/purchase.php?do=banner&zone=2

    XML Parsing Error: not well-formed
    Location: http://www.vabeertrail.net/wp-content/plugins/oiopub-direct/purchase.php?do=banner&zone=2
    Line Number 54, Column 27:<option value="2" selected> Side Bar Banner (150x150)</option>
    --------------------------^

    This is a different error than before.

    Wondering if this is of any help.

    Thanks much.

    Regards,
    Kory

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMay 31st 2015
     
    Project Admin

    Hmmm still looks to be the some root cause. The content type header is text/xml. I genuinely have no idea what has caused it, as OIO should never set that header itself (and I can't replicate it anywhere).

    You could try re-uploading 2.56 to see if it really is only triggered by that particular version.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeMay 31st 2015
     

    No go. Very confusing as the errors appear to be vastly different between Chrome and Firefox. Here's Chrome's error:

    This page contains the following errors:
    error on line 54 at column 22: Specification mandate value for attribute selected
    Below is a rendering of the page up to the first error.

    I also tried changing to another theme altogether and the same errors are still thrown so I immediately reverted back.

    I viewed the source on the banner ad signup page at:

    http://www.vabeertrail.net/wp-content/plugins/oiopub-direct/purchase.php?do=banner&zone=2

    I disabled all the plugins which had CSS files loading on that page yet the error persists.

    Interestingly enough when I enabled v2.56, the plugin is displaying the v2.60 version on the WP dashboard (I deactivated v2.60 but had left its directory still on my server) and the "latest news" on the OIO Publisher WP dashboard screen contains the following under latest news:

    This page contains the following errors:

    error on line 2 at column 1: Extra content at the end of the document
    Below is a rendering of the page up to the first error.

    Loading...

    I've been using RSS Multi-Importer to successfully import RSS feeds for over a year so I don't think it's a problem with any local RSS/XML issues on y server. (That was one of the plugins I disabled but to no effect.)

    My last ditch effort is updating PHP on my server. I'm hoping that'll work, otherwise, I'll need to abandon this plugin and try another solution.

    Regards,
    Kory

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeMay 31st 2015
     

    Hello, Simon. Alas, I've successfully updated PHP and Nginx on my server and the errors still persist. If there isn't anything that can be done, please let me know and I'll pursue other options.

    Thanks much.

    Regards,
    Kory

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeMay 31st 2015
     
    Project Admin

    I know the errors in FireFox and Chrome look different, but it's all the same thing (they just show different error messages, when invalid XML is encountered).

    The only suggestion I have is if you sent me temporary FTP access to the server I could try and isolate what is setting the content-type to text/xml. There's not much else I can do, since I'm fairly certain at this point is isn't actually a problem with OIO itself.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeJun 1st 2015 edited
     

    Thanks for that info, Simon. I created an FTP account for you. Do you have an email address or private messaging client I can send those credentials? May I also get your IP address too? I've set up a firewall to allow access only from certain locations.

    FYI, I had even totally removed OIO Publisher from both the site and database and reinstalled. After I removed the zones, I was able to get past that error. So I tried recreating the zones, thinking maybe a problem using a special character, e.g. & or # might have prevented but to no avail.

    I also checked out my mime type file for nginx and confirmed xml is there.

    Regards,
    Kory

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJun 7th 2015
     
    Project Admin

    The email address would be admin[at]oiopublisher[dot]com. If you email me there I can also send you my IP.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorvakory
    • CommentTimeJun 7th 2015
     

    Thanks, Simon. I sent you two emails: one containing the server's IP address and the FTP username and the other containing the password.

    Regards,
    Kory

    Need help?  Quick start guide | Troubleshooting | All help topics