Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorYAJones
    • CommentTimeJul 8th 2015
     

    Hi,

    I've set up rotating ads on my site in various zones (header, sidebar, above post, etc.) and when I load the page with those ads, the ads appear... at first.

    Then they disappear after my specified time (I use 10 seconds).

    Now, when I refresh the page, the ads return as they should, but after 10 seconds a new set of ads rotate and the system words perfectly as it should!

    What I don't understand is why the ads disappear the first time around. I don't want uses to have to refresh the page in order to see the ads!

    Is there a reason this is happening?

    Here's an example of a blog post on my website: http://embracedominica.com/blog/2015/07/07/photo-critic-name-this-cruise-ship/

    I use the text widget for my sidebar ads.

    Here's the configuration for my Sidebar ad zone (screenshot).

    Any help would be great. Thanks.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJul 11th 2015 edited
     
    Project Admin

    Sorry for the delay. I think I've tracked the problem down to a specific conflict with your site. The ads are having their opacity set to zero by the following css in your theme's stylesheet:

    body.td-animation-stack-type0 .td-animation-stack .entry-thumb, body.td-animation-stack-type0 .post img {
    opacity: 0;
    }

    To try and stop that happening I've updated OIO's "/images/style/output.css" file to force opacity to 1 for OIO ad zones. Download the latest OIO files and re-upload that file to see if it helps. If it doesn't, you'd need to edit that css in your theme's stylesheet to stop the conflict.

    P.S. I also noticed a small error in one of the OIO javascript URLs that stops it refreshing at all (a " in the middle of the url, before &refresh=12).

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorYAJones
    • CommentTimeJul 12th 2015
     

    Hi Simon,

    I tried the first method and it did not work: in one session ads will appear and rotate as they should; but in another session or when the page is refreshed, the ads disappear instead of rotating.

    This only happens with the sidebar ads though.

    How do I edit my theme's stylesheet to stop the conflict? I'm not a coder... what do I need to change and where can I change it?

    Thanks.

    Need help?  Quick start guide | Troubleshooting | All help topics