Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

  1.  

    Recently I have noticed that OIO loaded into Wordpress is producing the following errors when ad zones are loaded on pages loaded with https://

    ----------------

    Mixed Content: The page at 'https://scrapbookexpo.com/' was loaded over HTTPS, but requested an insecure stylesheet 'http://scrapbookexpo.com/wp-content/plugins/oio/images/style/output.css?260'. This request has been blocked; the content must be served over HTTPS.

    Mixed Content: The page at 'https://scrapbookexpo.com/' was loaded over HTTPS, but requested an insecure image 'http://scrapbookexpo.com/wp-content/plugins/oio/uploads/jjGurn_ToomuchPaper-Quote-SBC.jpg'. This content should also be served over HTTPS.

    -------------------

    I'm assuming it's a simple bit of Code to force https:// on loading of CSS and Images, but I don't know where to start.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJan 17th 2016 edited
     
    Project Admin

    I think I've found the cause of this one and fixed it. You just need to download the latest code again, which I've just updated.

    If you're already using v2.60, then the only files that need updating are:

    * /include/config.php
    * /include/output.php

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorpagerank
    • CommentTimeJan 18th 2016
     

    I have the same problem. Pages are displaying as "encrypted" but with warnings due to the above error. I just updated OIO a minute ago and do not see any change:

    /images/style/output.css?260'. This content should also be served over HTTPS.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeJan 22nd 2016
     
    Project Admin

    Would you be able to link to the site in question so I can have a look?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorpagerank
    • CommentTimeAug 25th 2016
     

    I solved this by editing include/output.php

    Removed:

    " . $oiopub_set->plugin_url . "

    Replaced with

    /wp-content/plugins/oiopub-direct

    This worked. Are there any problems I will face with doing it this way?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeAug 29th 2016
     
    Project Admin

    As long as you keep the OIO url the same, then there shouldn't be any side effect.

    Are you using the rewrite url option? Trying to think why the plugin_url would be out of sync.

    Need help?  Quick start guide | Troubleshooting | All help topics