Purchase OIOpublisher now for just $47.

Take control of your ad space.

Click here to purchase

    • CommentAuthorfuyutski
    • CommentTimeSep 2nd 2016 edited
     

    Hi Simon,

    Sorry to bother you again. I've implemented the fix you've mentioned here, but now have another problem.

    Effectively, I have two ad purchases on a particular ad zone (out of the three possible), and when I'm logged in, they look like:

    Which is how I want it to look like! However, when I'm logged out, it looks like:

    As first, I wondered why it wasn't showing up -- but then wondered if it could be the spacing fix you suggested (as it assigns a fixed height; and a fixed height for a single ad in an ad zone is, of course, different from multiple). So I made the edits to the css and increased the height value, and now it looks like this (also logged out):

    However, when I'm logged in -- it looks all nice and good; and when I'm logged out, once changing the height, it is all expanded out and I'm missing the 'Advertise Here'.

    I'm assuming this is the caching plugin I use (WP-Rocket), and if this is the case -- is there a particular CSS or JS file I should put as an exception in the cache settings?

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeSep 4th 2016
     
    Project Admin

    I looked back at your site again and it then struck me that OIO's own css file appears to be missing, which might actually have been the cause of the original problem. It is put in by OIO automatically, notmally.

    The css file is located in /oiopub-direct/images/style/output.css

    I'm not sure exactly how you deal with it in Rocket, but if that css file is there then you may be able to remove the spacing fix too.

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorfuyutski
    • CommentTimeSep 4th 2016
     

    Hi Simon,

    Thank you for that! I forgot to check whether the css was being minified (it was).
    I've added the url (modified as the original folder has been renamed in the htaccess) in the exceptions, and that cleared it up. I feel silly now -- because on reflection that makes total sense as to why it loaded properly when I was logged in (minification was off), and not when I was not.

    A tool that WP-Rocket provide, which might be useful for you also is: http://wp-rocket.me/tools/wp-rocket/debug/minify/

    Thanks again!

    Need help?  Quick start guide | Troubleshooting | All help topics
    • CommentAuthorSimon
    • CommentTimeSep 11th 2016
     
    Project Admin

    No worries, glad it did the trick.

    Need help?  Quick start guide | Troubleshooting | All help topics